Difference between revisions of "Gajim"

From postmarketOS
Jump to: navigation, search
(Initial docs.)
 
m
Line 1: Line 1:
# Installation
+
= Gajim on postmarketOS =
 +
== Installation ==
 
First setup the dependencies
 
First setup the dependencies
  
Line 11: Line 12:
 
This should even create a  
 
This should even create a  
  
# Known issues
+
== Known issues ==
  
 
At the first start Gajim used 100% CPU for a longer time - this was probably due to the fact that I was a member of a few big MUCs.
 
At the first start Gajim used 100% CPU for a longer time - this was probably due to the fact that I was a member of a few big MUCs.
  
# Possible first steps
+
== Possible first steps ==
  
 
It may be a good idea to start the MUCs minimized.
 
It may be a good idea to start the MUCs minimized.
  
# Which server should I choose?
+
== Which server should I choose? ==
  
 
See this page for information about compliance with modern XMPP extensions: https://conversations.im/compliance/
 
See this page for information about compliance with modern XMPP extensions: https://conversations.im/compliance/

Revision as of 11:57, 19 May 2018

Gajim on postmarketOS

Installation

First setup the dependencies

   sudo apk add g++ python3-dev py3-gobject3 alpine-sdk openssl-dev libffi-dev gettext

Then download the source tarball from https://gajim.org/downloads.php?lang=en#source unpack it, enter the directory and execute

   pip3 install --user .

This should even create a

Known issues

At the first start Gajim used 100% CPU for a longer time - this was probably due to the fact that I was a member of a few big MUCs.

Possible first steps

It may be a good idea to start the MUCs minimized.

Which server should I choose?

See this page for information about compliance with modern XMPP extensions: https://conversations.im/compliance/