Difference between revisions of "Hybris"

From postmarketOS
Jump to: navigation, search
(turn some of @drebrez hybris chat notes into a wiki article)
 
(explicitly state that hybris devices will not be featured devices)
Line 1: Line 1:
[https://en.wikipedia.org/wiki/Hybris_(software) Libhybris] allows devices lacking FLOSS drivers to make full use of their hardware by using the proprietary drivers from Android. Mainlining and using free software drivers is of course the better approach, but it is not possible for all devices.
+
[https://en.wikipedia.org/wiki/Hybris_(software) Libhybris] allows devices lacking FLOSS drivers to make full use of their hardware by using the proprietary drivers from Android. Mainlining and using free software drivers is of course the better approach, but it is not possible for all devices. '''We will not list devices that need hybris as featured devices''' (see {{issue|83|postmarketos.org}}).
  
 
== Using libhybris with your device ==
 
== Using libhybris with your device ==

Revision as of 02:32, 12 November 2018

Libhybris allows devices lacking FLOSS drivers to make full use of their hardware by using the proprietary drivers from Android. Mainlining and using free software drivers is of course the better approach, but it is not possible for all devices. We will not list devices that need hybris as featured devices (see postmarketos.org#83).

Using libhybris with your device

This is a stub copied from chat messages in #postmarketOS. Please extend if you are porting your device to libhybris.

  • convert the halium system.img to a mountable image (basically what the halium install script does)
  • install postmarketOS on the device without user interface and copy the new system.img to the device, to /var/lib/lxc/android/system.img
  • install the hybris related packages:
$ sudo apk add lxc-android xf86-video-hwcomposer libhybris libhybris-egl libhybris-gles libhybris-7.1-caf wayland-libs-client wayland-libs-server
  • start the service:
$ sudo rc-service lxc-android start

See also