Difference between revisions of "Pmaports.cfg reference"

From postmarketOS
Jump to navigation Jump to search
(→‎Section reference: add supported_firewall)
Line 33: Line 33:
 
| One of the release channels defined in [[channels.cfg reference|channels.cfg]]. While channels.cfg already defines the pmaports branch related to a given channel, it is needed to save the channel in pmaports.cfg of each branch as well, so we know to which channel a forked branch belongs.
 
| One of the release channels defined in [[channels.cfg reference|channels.cfg]]. While channels.cfg already defines the pmaports branch related to a given channel, it is needed to save the channel in pmaports.cfg of each branch as well, so we know to which channel a forked branch belongs.
 
| <code>edge</code>, <code>stable</code>
 
| <code>edge</code>, <code>stable</code>
 +
|-
 +
| <code>supported_firewall</code>
 +
| Set to <code>nftables</code> if the nftables-based [[firewall]] is supported ({{MR|2042}}, {{MR|2060|pmaports}}).
 +
| <code>firewall</code>
 
|-
 
|-
 
| <code>supported_root_filesystems</code>
 
| <code>supported_root_filesystems</code>

Revision as of 13:01, 19 June 2021

pmaports.cfg is present on each branch of pmaports.git and holds various metadata parsed by pmbootstrap.

Example

# Reference: https://postmarketos.org/pmaports.cfg
[pmaports]
version=7
pmbootstrap_min_version=1.29.0
channel=edge
supported_root_filesystems=ext4,f2fs

Section reference

The file only has one section, pmaports.

Variable Description Possibles values
version pmbootstrap compares this with pmb.config.pmaports_min_version and complains if this version isn't at least as high as the version that pmbootstrap requires.

Do not change. This variable was fine when we were only using edge. But now that we have release branches, we have different pmaports branches supported at the same time with different feature sets. These features should be described with supported_* variables (see below). This makes it more descriptive and more flexible (allows backporting only specific features), and by not increasing pmaports_min_version in pmbootstrap, we don't break compatibility with old release channels.

7
pmbootstrap_min_version pmbootstrap compares this with pmb.config.version and complains if this branch of pmaports needs a newer pmbootstrap version 1.17.0
channel One of the release channels defined in channels.cfg. While channels.cfg already defines the pmaports branch related to a given channel, it is needed to save the channel in pmaports.cfg of each branch as well, so we know to which channel a forked branch belongs. edge, stable
supported_firewall Set to nftables if the nftables-based firewall is supported (!2042, pmaports!2060). firewall
supported_root_filesystems Comma-separated list of filesystems, which postmarketos-mkinitfs supports. pmbootstrap install --filesystem will complain if trying to use a filesystem that is not supported (!2011, pmaports!1850). ext4,f2fs (Default: ext4)