Difference between revisions of "Repository maintenance"

From postmarketOS
Jump to: navigation, search
(kde packages that need to be upgraded after qt upgrade)
 
(See also)
Line 11: Line 11:
 
== See also ==
 
== See also ==
 
* [https://github.com/postmarketOS/pmOS-repo-scripts pmOS-repo-scripts]
 
* [https://github.com/postmarketOS/pmOS-repo-scripts pmOS-repo-scripts]
 +
* {{github|1458}} Fixing the repo after QT upgrade to 5.10.1

Revision as of 19:14, 2 May 2018

This page is about maintaining the official binary package repository of postmarketOS. It does not relate to the local package repository that pmbootstrap creates when compiling packages. So most people will not need this.

QT upgrade

There are KDE packages, which need to be rebuilt after each QT upgrade:

$ pmbootstrap pkgrel_bump kwayland kwin plasma-framework kdeclarative

See #978 for an idea to automatize this and for more information.

See also