Samsung Galaxy Tab 2 7.0" (samsung-espresso3g)

From postmarketOS
Jump to navigation Jump to search
Samsung Galaxy Tab 2 7.0
Samsung Galaxy Tab 2 7.0
Samsung Galaxy Tab 2 7.0
Manufacturer Samsung
Name Galaxy Tab 2 7.0
Codename samsung-espresso3g
Released 2012
Category testing
Original software Android
postmarketOS kernel 3.0.101 and 5.12-rc1
Hardware
Chipset TI OMAP 4430
CPU Dual-core 1.0 GHz
GPU PowerVR SGX540
Display 7.0 inches, 137.9 cm2 (~58.2% screen-to-body ratio) 600 x 1024 pixels, 16:9 ratio (~170 ppi density)
Storage 8/16/32 GB
Memory 1 GB
Architecture armv7
Unixbench Whet/Dhry score 415.1
Features
USB Networking
Works
Flashing
Works
Touchscreen
Works
Display
Works
WiFi
Xwayland
FDE
Mainline
Works
Battery
3D Acceleration
Partial
Accelerometer
Works
Audio
Bluetooth
Camera
GPS
Mobile data
SMS
Calls
USB OTG
NFC
Unavailable



Contributors

  • Mighty

Users owning this device

How to enter flash mode

Press Power + Volume Up to enter download/odin mode. Press Power + Volume Down to enter recovery.

What works (downstream)

  • Display
  • Touch
  • Mate
  • WiFi (using nmtui in terminal)
  • Battery

Hardware status (mainline)

Status Hardware Info
Y Panel Samsung LTN070NL01 LCD panel
Y Touchscreen MMS136
Y SD cards MicroSD card.
Y Internal memory
N GPS
Y WiFi Uses BCM4330B1.
P Bluetooth Uses BCM4330. (Firmware issue?)
N GPIO keys There are 2 keys on GPIO: Volume up, Volume down.
P Charger SMB136 WIP by mighty17
Y Fuel Gauge MAX17042
Y PMIC TWL6032
N Sound Sound codec is WM8994.
Y Accelerometer BMA254
Y Magnetometer YAS530
N Proximity and Light The P3100 variant has GP2A002, P3110 variant has AL3201.
N Cameras Front - SR030PC50 Back - S5K5CCGX (OMAP4 devices have Ducati firmware for cameras)
P GPU PowerVR SGX 540 needs out-of-tree kernel module, patched mesa, and some proprietary blobs

STATUS

Display

OMAPDRM works fine.

Display seems to be running at 30Hz due to the clock speed for 60Hz not working properly.

Brightness needs a correct PWM clock value until that is done it flickers at low brightness.

Touchscreen

Touchscreen is MMS136 and it works fine. Already in upstream.

Bluetooth

Bluetooth does not work, looks like firmware has some issue (?).

Battery

Fuel gauge works fine. The charger driver is WIP, if connected to usb during boot, then only it charges.

Camera

OMAP4 has different subsystem (Ducati) for camera which is non free. Probably will never work on mainline.

3D GPU Acceleration

3D acceleration works fine. It crashes sometimes like when opening firefox. Video decoding does not work as it is done by Ducati subsystem.

See also

Downstream kernel:

Mainline WIP kernel:

Screenshots