Open main menu

postmarketOS β

Samsung Galaxy Tab S2 9.7 Wifi (samsung-gts210vewifi)

Revision as of 14:23, 29 March 2018 by K-laus (talk | contribs) (Installation: document that heimdall flashing does not seem to work, just pretends to be successful)
Samsung Galaxy Tab S2 9.7 Wifi
Samsung Galaxy Tab S2 9.7 Wifi
Samsung Galaxy Tab S2 9.7 Wifi
Manufacturer Samsung
Name Galaxy Tab S2 9.7 Wifi
Codename SM-T813, gts210vewifi
Released 2016?
Category testing
Original software Android 7.0
Hardware
Chipset Qualcomm MSM8976 Snapdragon 652
CPU Octa-core Cortex-A53 & Cortex-A72, 4 x 1.8 GHz & 4 x 1.4 GHz
GPU Adreno 510
Display 1536x2048 (264 PPI) HD Super AMOLED
Storage 32 GB
Memory 3 GB
Features
USB Networking
Flashing
Touchscreen
Display
WiFi
Xwayland
FDE
Mainline
Battery
3D Acceleration
Accelerometer
Audio
Bluetooth
Camera
GPS
Mobile data
SMS
Calls
USB OTG


Contents

Contributors

  • K-laus

Maintainer(s)

  • K-laus

What works

  • compiling kernel

What does not work

  • booting
  • everything else

How to enter flash mode

  • Recovery: With the device powered off, hold Home + Volume Up + Power.
  • Download: With the device powered off, hold Home + Volume Down + Power.

Sometimes, to enter Recovery it is needed to first enter Download mode, then again hold Home + Volume Down + Power and while screen goes blank, switch to hold Home + Volume Up + Power.

Unlocking

In Android go to settings -> System -> About phone and tap the build number 7 times. Then go to settings -> system -> developer options and enable OEM unlocking

Installation

  • had problems with "heimdall flash --KERNEL ..." command used by "pmbootstrap flasher flash_kernel", it did stop with "ERROR: Partition "KERNEL" does not exist in the specified PIT."
  • flashing via heimdall does not seem to work - device uses lowercase partition labels which are not supported by heimdall, e.g.
   pmbootstrap flasher flash_system --partition userdata
 gives:
   ERROR: Partition "userdata" does not exist in the specified PIT.
 if using uppercase "USERDATA" then flashing seems to work:
   pmbootstrap flasher flash_system --partition USERDATA
 but does not, as userdata partition size is 0 after that command (seen by TWRP recovery)
 same for "SYSTEM" and "BOOT" partitions
  • so did flash via TWRP recovery zip file, but after trying to boot: no screen output, no connectivity.

See also