Difference between revisions of "Upstreaming"

From postmarketOS
Jump to navigation Jump to search
(Adding a merged pull request to the successful ones)
Line 26: Line 26:
 
* apk-file: New package, command line usage for pkgs.alpinelinux.org {{github|1011}}
 
* apk-file: New package, command line usage for pkgs.alpinelinux.org {{github|1011}}
 
* abuild: Add a compression flag to override the default of highest compression (right now we install a [https://github.com/postmarketOS/pmbootstrap/blob/34e2f8093c6cf6571815a82865309b02d31b5d0c/pmb/build/init.py#L61 wrapper] that converts <code>-9</code> to <code>-1</code> to improve performance)
 
* abuild: Add a compression flag to override the default of highest compression (right now we install a [https://github.com/postmarketOS/pmbootstrap/blob/34e2f8093c6cf6571815a82865309b02d31b5d0c/pmb/build/init.py#L61 wrapper] that converts <code>-9</code> to <code>-1</code> to improve performance)
 +
 +
[[Category:Technical Reference]]

Revision as of 15:06, 27 December 2018

Upstreaming new packages to Alpine should only be done when you are willing to maintain the package (update it when there's a new version from upstream, or a security hole gets discovered etc.).

It is important for us to contribute the patches and improvements we made to various software back to the original project. So everyone can benefit from the improvements and we don't need to maintain and carry around patches.

Successful

Work in progress

Not started, but should/could be done in the future

  • apk-file: New package, command line usage for pkgs.alpinelinux.org #1011
  • abuild: Add a compression flag to override the default of highest compression (right now we install a wrapper that converts -9 to -1 to improve performance)